need firmware for OEM N9200, mt6580

there is no logo or any branding on the phone, it is stuck at boot logo.

this is info I could read:

Code:


Wait for phone...
Phone found! [ 402 ]
Sync...
Inital Boot Ok!
BB_CPU_PID : 6580
BB_CPU_NME : [MediaTek] MT6580_S00
BB_CPU_EXT : 0xCA00 , 0x8A00 , 0x0000
Processing BROM stage
Settings for BROM configured!
SecCfgVal : 0x00000000
BromVer  : 0x00FF
BLVersion : 0x0001
PreLoader : Active [ Boot with PL ]
BootLdrSS : NORMAL with PRELOADER
Processing DA stage
DA Select done, will use MTK_AllInOne_DA_v5.1624.16.07
Sending and initialize DA ...
Running DA ver.4.2 on BBID : 0x94
NAND Flash : NOT INSTALLED
eMMC Flash : 3701FF454D4330384710F600021F137D
Initialize Memory ...
DRAM already initialized by Preloader
DAgent sent , init HW now
eMMC FlashIC initialized
[eMMC] : FLASH_VEN : 0x37 , OEM : 01FF
[eMMC] : FLASH_INF : [NOT_IN_BASE] , G80CM
[eMMC] : FLASH_CID : 3701FF454D4330384710F600021F137D
[eMMC] : FLASH_BRT : 0x00400000 , 0x00400000 , 0x00400000
[eMMC] : FLASH_LEN : 0x00000001CD000000
[eMMC] : FLASH_UCP : 7376 MiB [eMMC 8 GiB]
DEV RID    : 0x0D01E5849D117FE95D2EBB302856D23F
INT RAM    : 0x00020000
EXT RAM    : 0x40000000 [1 GiB]
BOOT TYPE  : EMMC_FLASH_BOOT
SOC VERIFY : C1
Boot Ok!

[AP] : Initial info read Ok!

Brand    : OEM
ProdName  : N9200
ProdModel : N9200
Device    : N9200
AndroidVer: 5.1
MTKxCPU  : MT6580
MTKxPRJ  : ALPS.L1.MP6.V2_YUANDA6580.WE.L

MODEM :
BaseBand  : MT6580_S00_MOLY_WR8_W1449_MD_WG_MP_V6_P2_1_wg_n

EXTRA :
LCD : Not info available 🙁
LCD Res : 960x540
TOUCH [0] : GT9XX
CAM [0] : gc2145_mipi_yuv
CAM [1] : gc2355_mipi_raw
CAM [2] : gc2755mipi_raw
CAM [3] : gc0409mipi_raw
CAM [4] : imx219_mipi_raw
CAM [5] : ov9760_mipi_raw
CAM [6] : ov5693_mipi_raw
CAM [7] : imx164_mipi_raw
CAM [8] : s5k4ecgx_mipi_yuv
CAM [9] : ov5648_mipi_raw
CAM [10] : gc5024mipi_raw
MODEM : yuanda6580_weg_l_hspa_850_2100
LOCALE : K_PRODUCT_LOCALES =en_US ja_JP zh_TW zh_HK zh_CN af_ZA az_AZ in_ID ms_MY ca_ES cs_CZ da_DK de_DE et_EE es_ES tl_PH fr_FR hr_HR zu_ZA it_IT sw_TZ lv_LV lt_LT hu_HU nl_NL nb_NO pl_PL pt_PT pt_BR ro_RO rm_CH sk_SK sl_SI fi_FI sv_SE  tr_TR el_GR bg_BG mn_MN ru_RU sr_RS uk_UA ka_GE hy_AM iw_IL he_IL ar_EG ar_IL fa_IR am_ET ne_NP hi_IN  bn_IN th_TH lo_LA ko_KR is_IS eu_ES en_GB es_US ur_PK te_IN  ta_IN mk_MK fr_CA

Done!
Elapsed: 00:00:15
Reconnect Power/Cable!


And this is info when reading firmware

Code:


Wait for phone...
Phone found! [ 402 ]
Sync...
Inital Boot Ok!
BB_CPU_PID : 6580
BB_CPU_NME : [MediaTek] MT6580_S00
BB_CPU_EXT : 0xCA00 , 0x8A00 , 0x0000
Processing BROM stage
Settings for BROM configured!
SecCfgVal : 0x00000000
BromVer  : 0x00FF
BLVersion : 0x0001
PreLoader : Active [ Boot with PL ]
BootLdrSS : NORMAL with PRELOADER
Processing DA stage
DA Select done, will use MTK_AllInOne_DA_v5.1624.16.07
Sending and initialize DA ...
Running DA ver.4.2 on BBID : 0x94
NAND Flash : NOT INSTALLED
eMMC Flash : 3701FF454D4330384710F600021F137D
Initialize Memory ...
DRAM already initialized by Preloader
DAgent sent , init HW now
eMMC FlashIC initialized
[eMMC] : FLASH_VEN : 0x37 , OEM : 01FF
[eMMC] : FLASH_INF : [NOT_IN_BASE] , G80CM
[eMMC] : FLASH_CID : 3701FF454D4330384710F600021F137D
[eMMC] : FLASH_BRT : 0x00400000 , 0x00400000 , 0x00400000
[eMMC] : FLASH_LEN : 0x00000001CD000000
[eMMC] : FLASH_UCP : 7376 MiB [eMMC 8 GiB]
DEV RID    : 0x0D01E5849D117FE95D2EBB302856D23F
INT RAM    : 0x00020000
EXT RAM    : 0x40000000 [1 GiB]
BOOT TYPE  : EMMC_FLASH_BOOT
SOC VERIFY : C1
Boot Ok!

Reading Flash Content now ...

xGPT : Normalize settings Ok!

Brand    : OEM
ProdName  : N9200
ProdModel : N9200
Device    : N9200
AndroidVer: 5.1
MTKxCPU  : MT6580
MTKxPRJ  : ALPS.L1.MP6.V2_YUANDA6580.WE.L

[Read Ok] : preloader_yuanda6580_we_l.bin
[Read Ok] : lk.bin
[Read Ok] : boot.img
[Read Ok] : recovery.img
[Read Ok] : logo.bin
[Read Ok] : secro.img
[Read Ok] : system.img
[Read Ok] : cache.img
[Read Ok] : userdata.img

[ScatCFG] : MT6580 / V1.1.2 / yuanda6580_we_l / EMMC
Android Info saved
MAUI Meta DB saved
HWConfig Info saved
FW Size : 1656 MiB
Scatter saved to : E:\MT6580__OEM__N9200__N9200__5.1__ALPS.L1.MP6.V2_YUANDA6580.WE.L\

All done!

Done!
Elapsed: 00:09:46
Reconnect Power/Cable!


I read flash and nvram, ERASED whle flash except bootloader, rewrote the Read Firmware, wiped everything, run antivirus oiperation, etc.
still hung on boot logo

Any idea of another firmware which maybe could be compatible with this phone?

it is a note 5 clone